Seatable trigger sends null values and ignores poll times

Describe the issue/error/question


I need to get notified when rows are updated in Seatable.
For this, I configured the n8n Seatable trigger connection (Cloud-Hosted) and provided the API Token of the Base.

What is the error message (if any)?

When I click Execute Workflow, I Automatically receive null values and poll time interval is not respected. Also, there is no difference if Simplify is checked or not.

It is not clear to me how this trigger is working. Normally, you’d have to set up a webhook in Seatable Base → Advanced Settings and then insert the same webhook in your trigger node/module, etc.

I can only see a Base Token required in n8n and I do not understand the output I receive from this trigger. Seems to not be related to any change or row addition in Seatable. The response with null values is just sent automatically when I click Execute Workflow.

Is it possible to subscribe to row update notifications? This would be the use case for my project and I can only see “Row Created” option for event subscription.

Thank you in advance!

Information on your n8n setup

  • n8n version: 0.208.1
  • Running n8n: Self-Hosted

Hi @alexnemes, I am sorry to hear you are having trouble.

This trigger uses a polling approach and I remember it was quite a pain to build this in the first place as SeaTable uses different time zones in different parts of their platform without documenting them. This might also be what causes the polling to take place at unexpected times for you or to miss some rows.

You’re quite right though, webhooks are now available from checking Webhooks - SeaTable and should be much easier to work with. You can use n8n’s Webhook node to get a webhook URL for use with SeaTable. Make sure to set the right HTTP method (POST) and keep in mind that n8n’s webhook URLs are only active when you either manually execute your workflow (in this case the webhook test URL is active) or when your workflow is active (in this case the webhook production URL is active).

Thank you @MutedJam that way is working.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.