Send Mail Node Timeout Error

Describe the issue/error/question

Send Mail Node doesn’t send mail and gives timeout error.

I tried with my gmail account’s app password and my gmail account’s own password.

I also tried with a custom mail address. From the SMTP server of “

What do I do wrong?

What is the error message (if any)?



custom mail;


Please share the workflow

I also tried without any CC or BCC

Information on your n8n setup

  • n8n version: Version 0.209.4 , self-hosted

Same issue here. The “Send Email” node worked on our Railway deployment, but not anymore on our self-hosted docker container.

1 Like

Which version are you using? I also having this problem on self-hosted environment. @BramKn @MutedJam @Jon @jan

Hi There,

Connection timeout typically indicates a network issue and it could be that the port is being blocked by a firewall on the way out which can be common with some hosting providers to prevent spam.

Would be handy to know where n8n is being hosted and we can dig into it from there.

Hey @Jon,

Thank you for your quick direction.

So you mean I should connect to the server where n8n is being hosted and open a port? Or you need some info about server?

Hey @onurbolaca,

Where it is hosted may help but the quick version would be that the mail port 465 or 587 would need to be open for outbound traffic.

Some hosts like Scaleway will tend to block this by default.

1 Like

Hi @Jon i currently do have the same issue. The server is hosted on hetzner. No network firewall configured and the servers ufw also allows all outgoing ports.

We have solved it,

Thanks @JUVOJustin and @Jon ,

With any mail provider’s smtp address,

After opening the port for 465 , 587, 25

Use ssl/tls port 587 and do not disable the ssl/tls button;

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.