Sending application/octet-stream but cannot read response - add Full Response

I was sending PDF files through the http request node and couldn’t read the response. I asked the community but managed to solve it so I changed it into a tip instead if anyone else have this question :wink:

The response from the server should look something like this:

  • “status”: 0,

  • “message”: “string”,

  • “id”: “jhgljhg2423234jkhjkg”


But instead I just see the last item from the previous node. I guessed I need to add something in the node for it to expect an incoming JSON response.

My headers were {{ {“api-key”: “XXXX”,“content_length”: $node[“Get File Size”].json[“bufferSize”]} }}

I solved it by adding “Full Response” in the options dropdown and JSON in the Response.

1 Like