"Server refused the connection" connecting to Baserow

I’ve been trying to setup a workflow in n8n to update Baserow.

I have Baserow (v. 1.19.1) and n8n (v. 1.1.1) running on my MacBook (Ventura) using Docker following the [guides on the Baserow site](https://baserow.io/blog/link-multiple-baserow-rows?utm_source=community&utm_medium=social&utm_campaign=bulk%20row%20linking#5-add-credentials-on-n8n-to-authenticate-nodes). I’ve created credentials in n8n with my Baserow username and password.

When I try to set up the Baserow node, I select the credentials, but the “Database Name or ID” and “Table Name or ID” and “Row ID” fields turn red with the error message: "There was a problem loading the parameter options from server: “The service refused the connection - perhaps it is offline.” I am therefore unable to create the workflow. Screencap attached.

Ultimately I want to copy one column of numbers into another column of numbers to create linkages between two tables.

Hey @thelorax76,

Welcome to the community :tada:

Are you using the correct host for your Baserow instance? As an example if you have both n8n and Baserow in docker and you set n8n to look at localhost / for Baserow it will fail to connect and you would need to make sure you are using the correct Docker IP or Hostname for your Baserow instance.

1 Like

Originally I had localhost in that field. But we tried changing it (in n8n credentials for Baserow) to and, and neither of those seem to have made any difference.

Update: I have it working now after starting with a new Baserow container in Docker. Not sure why it didn’t work the first time.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.