Set default custom cron to 5 inputs instead of 6

Not sure if this was intentional but it ended up bottle necking my server running every second since I didn’t notice while setting up the node


Sorry to hear that you had problems!

The goal of n8n is that every none technical person can use it but still be flexible and powerful enough to also be used by technical people. The “custom” mode on the Cron-Node is mainly meant for those technical people. They should be able to define that a task should run at a specific second or all x seconds only on Tuesdays from 7-12.
Also would it not be possible to change that now without breaking it for existing users.

Anyway, what could be done is to add an additional option for “Every Minute” so that people do not have to use the “custom” mode to do that which could cause problems like you experienced them.

:sweat_smile: It’s no problem. I’m used to seeing 5 in most places. Just hope this helps other people avoid potentially soft locking their system. An option for Every Minute would be a good compromise

Great to hear and thanks for the report. Will add the “Every Minute” option to hopefully avoid such problems.

1 Like

@jan Send you a PR adding this!

@RicardoE105 Thanks a lot! Is merged. Will release a new version with the addition later today.