Slack App can't connect to N8n

Describe the problem/error/question

As I am trying to configure my Slack credentials (including Client ID and Secret) in my self-hosted (in Docker) N8n instance for a single node, as it asks me to connect the account in order to finish authentication, it opens the popup asking for permission, I accept it, but then it displays the following error message:
imagem

I have tried to disable my Firewall, but it did not work.

Information on your n8n setup

  • n8n version: 1.18.0
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker):
  • Operating system: Windows 11

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Carrico,

That looks like you are trying to connect to n8n.example.com is that what you have set the webhook_url environment variable to?

Yes exactly, the Slack authorization tries to connect to the webhook_url environment variable in the docker compose.

1 Like

Hey @Carrico,

That is perfect and is to be expected, Have you updated it now so that it can work with your own domain?

Excuse me but I’m a bit of a newbie here, how or to what should I update it to?

Hey @Carrico,

You should set it to your domain that points to your n8n instance so if you have n8n.carrico.com pointing to your n8n server you would set the environment variable to that.

Alright, many thanks, I think I kinda get it.
But just so I don’t muck it up, is there a comprehensive tutorial for that?

Hey @Carrico,

We don’t really have a tutorial for the stuff that needs to happen outside of n8n as there are hundreds of providers for domains and DNS.

1 Like