SMTP Password Keeps Changing

Hi - I’ve just signed up with N8N - I’m going through the initial demo, adding send email module as instructed

Problem I’ve got - every time I add my SMTP password and click save, the password I’ve just saved changes - well I say changes, it looks like it vanishes completely.

  • n8n version: - whatever the latest cloud hosted one is
  • Database (default: SQLite): don’t know - just using the demo
  • n8n EXECUTIONS_PROCESS setting (default: own, main): - default as far as I’m aware
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system: mac ventura 13.5

I’ve tried logging out and in again - and tried in a different browser - same problem

So, basically I can’t use n8n at all currently

Can anyone help?

Tried to attach a screenshot but I can’t see where to (sorry for being such a newbie)

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
1 Like

hello @weareingenius

Please, do not use the expression button in the password section. Hit the Fixed button, enter the password and hit Save. The password will be hidden behind the asterisks and it’s fine. You won’t be able to retrieve it in clear text

thanks - unfortunately exactly the same thing is happening. I was pretty sure I’d already hit fixed rather than expression already - I was just showing the expression in the screenshot to show what it keeps reverting to

My password is 12 characters long - that screenshot is not the password I saved in there

so it appears to me that rather than saving it, it’s deleting the password and then adding that expression in there to show that it’s now a blank field?

It’s ok, that you see more symbols after you have saved your password. Because it was converted to some encrypted value and stored inside n8n. You can’t retrieve it back, that’s how the credentials work. Just use the credentials in the Email node and everything should be fine :slight_smile:

1 Like

it’s still not accepting the login credentials though - I’m assuming it’s the password but, as always with setting up email it’s a trial and error thing so I’ll keep playing

appreciate the help

Usually, SMTP accounts should have the @domain part. Try with it

So @barn4k has nailed it here, we don’t return the password back to the ui and we use a generic bit of text instead so you can’t easily extract the password.

The password will be stored correctly unless you changed to an expression and hit save which will replace it.

Depending on your mail provider the username is normally the email address so I would change that, it could also be that you have 2FA / MFA enabled for your mail account so it would then need an app password instead.