Some cortex nodes doesn't work properly

Hi team,

Hope you are doing well.
I trying to use multiple cortex analyzers as you can see in the attached screenshot.
The problem is that the second analyzer is not returning data even if it was executed with success.
The problem is on the next node where i want to get respective job details. I’m not able to find the id to perform a query because it’s not returning results to n8n.

The Node that it’s not returning results.

Thanks in advance

Is it posible that the job has not finished processing yet and that is why it returns empty? I would try to following:

  1. Increase the timeout in the node.
  2. Add a small wait before calling the job:get (see example).
1 Like

Thank you @RicardoE105.
I did that. Your suggestion as you can see in the attached screenshot.
As you can see the cortex node down is acting in such a weird behavior.
I got the same result but the node is executed.

So it worked in the upper branch but not in the below one? That is weird. I do not think it’s an issue with the node but rather with the API.

Do you need to create an observable before executing an analyzer? Why is it different in the upper branch (where I think it works) from the below one?

I’m just trying to make sense. Sadly my knowledge of Cortex and TheHive is limited.