SSL connection issues with PostgreSQL node

I am trying to use the PostgreSQL node with SSL to connect to our RDS, but we are getting the error below

Error: unable to get local issuer certificate
    at TLSSocket.onConnectSecure (node:_tls_wrap:1532:34)
    at TLSSocket.emit (node:events:527:28)
    at TLSSocket._finishInit (node:_tls_wrap:946:8)
    at TLSWrap.ssl.onhandshakedone (node:_tls_wrap:727:12)

Error screenshot
https://www.awesomescreenshot.com/image/26663505?key=a94f49dd508bee0a96c0a04bf7150b30

when we select IGNORE SSL ISSUES it works, but I have to enable SSL for compliance reasons.

Is there any place to upload our PEM? Or any other SSL settings that I am missing?

Hey @Rodrigo_demetrio,

Welcome to the community :rocket:

The ignore ssl issues shouldn’t disable ssl it will just ignore errors about self signed certificates.

1 Like