Strapi v4 integration is broken?

Describe the problem/error/question

Strapi expects update to be present as “data”, when columns input just splits by comma and posts as is. I’ve tried creating the data object manually by using “Edit fields” and still the object gets posted with all fields as empty/default values.

What is the error message (if any)?

Before:
400 - {“data”:null,“error”:{“status”:400,“name”:“ValidationError”,“message”:“Missing "data" payload in the request body”,“details”:{}}} - Missing “data” payload in the request body

Now:
No error, but object is saved as empty.

Please share your workflow

Share the output returned by the last node

[
  {
    "data": {
      "id": 2,
      "attributes": {
        "stripeId": null,
        "cancel_at_period_end": null,
        "createdAt": "2023-11-09T14:16:03.568Z",
        "updatedAt": "2023-11-09T14:16:03.568Z"
      }
    },
    "meta": {
      
    }
  }
]

Information on your n8n setup

  • n8n version: cloud
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @articice, I am sorry you are having trouble. This suggests you might be sending one (or more) empty items to Strapi.

Can you share an example of the JSON data you are sending to your Strapi node using which the problem can be reproduced?

Hello guys I came here because I had the same problem, I was sending all the required information from insomnia and it seemed that there was missing data, I simply downloaded postman and tried from there and it worked without a problem

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.