Stripe Trigger: No such webhook endpoint

I am getting this error when I try to active a node. It all works fine when I just listen to the event in test.

I’ve tried to delete the node, rename and activate again but still get the same error.

What to do?

Screenshot 2022-10-19 at 12.53.17

Hi @ericsonmartin, I am sorry to hear you’re having trouble. I wonder if the Stripe API has changed without us noticing. Which n8n version exactly are you running and is your n8n instance available under a public https URL? You can check this by expanding the webhook URLs section of the node like so:
image

Hi Jan,

I am using 0.192.2 and yes, the url’s are accessible.

I have a similar that is using this node that triggered about an hour ago.

(stupid question, can you have several flows using different account Stripe Triggers?)

So the trigger is working for you in another workflow, just not the current one?

From the n8n side of things you can have multiple trigger nodes (even in a single workflow if you like), though some services would only allow one webhook per account/application (webhooks are what the Stripe trigger uses under the hood). Not sure if Stripe is one of them, but I’ll see if I can find some time later this week to set up a test account myself and try this.

Regular Webhook works fine. So it’s no hurry from my side.

1 Like

Hey @ericsonmartin,

I have just tried to reproduce this one quickly and I am not able to, Could you try upgrading to 198.2 and seeing if you have an issue on that version as well?

In my test I had 3 triggers in the same workflow with no activation issues. Does it always happen or is there some set of events you take like activating, clicking listen now then saving?

Would love to upgrade but won’t have time in the coming weeks in case something happens.

It’s only the Stripe trigger that’s not possible. Doing a manual webhook works perfect.

I don’t think this is a general issue and I’m sorry I cannot investigate further.

Btw, the Stripe Trigger rename the ‘body’ to ‘data’.

I’m having exactly the same issue!

The Stripe trigger works fine when I have Listen For Event active but then when I try to activate the worksflow I get the error.

In the Stripe logs it show a 404 error:

This is with the Stripe node set to both live or sandbox credentials.

Hey @seank1968,

What version of n8n you are using?

I’m on 0.199.0

That should be ok, I have just given it a test here and I am able to enable it with no problems. Do you have another Stripe trigger in the worklfow?

How do you have n8n configured and installed?

No other Stripe triggers at all

Used the docker inage to install.

After a bit of experimentation, if I add the node and set it up then activate it works fine. As long as I dont edit the trigger again or disable the workflow. Editing other nodes in the workflow is ok toi

Hey @seank1968,

That is interesting, I will see if I can reproduce that one.

I am too having this same issue. When I listen for the stripe event it executes workflow. When I save and toggle active. I get teh same error message.

Thank you,
Alex

Hi @Jon, I’m having the same issue too. Does anyone have a fix other than setting up the webhook manually in Stripe?