Stripe trigger prob after update to 0.141.0

Hello,

I updated n8n from version 0.139.0 to 0.141.0 last night. Since then the trigger stripe is not working anymore.

Here is the response from the stripe API:

invalid_request_error - enabled_events
Invalid array

{
“url”: “XXXX”,
“enabled_events”: “payment_intent.payment_failed,payment_intent.canceled,payment_intent.succeeded”
}

Any idea ?

Sorry to hear that you have problems. Can you please try setting the environment variable N8N_USE_DEPRECATED_REQUEST_LIB to true and then restart and see if it works then.

Hey @MuMU sorry about the issue you’re having.

I created a fix for it here: Fixed body formatting for x-form-www-urlencoded by krynble · Pull Request #2269 · n8n-io/n8n · GitHub

It will be released soon. Tested and works fine with Stripe triggers.

2 Likes

Fix got released with [email protected]

1 Like

Great, thanks for the speed!

When I push the latest version via docker, it stays in 0.141.0 (and I see that you have pushed a new version in the dockerhub), any idea?

Sorry, do not understand. I assume you mean “pull” and not “push” and 0.141.1 gets displayed correctly fine me here: