Stripe webhook not working

Hello, I’m trying to set up a workflow that every time a customer completes a checkout session in stripe, it sends our team a slack notification.

I only made it work once, and most of the time stripe sends me this kind of message

““The requested webhook “POST XXXXXXXXXXX/webhook” is not registered.””

When I got it working, I tried to save the workflow but everytime I tried I got this error in n8n:

There was a problem and the workflow could not be activated:

404 - {“error”:{“code”:“resource_missing”,“doc_url”:“https://stripe.com/docs/error-codes/resource-missing",“message”:"No such webhook endpoint: ‘we_1I3MZZDw6nF3ywWN8AfK3KLz’”,“param”:“webhook_endpoint”,“type”:“invalid_request_error”}}

Can you help me?

There seem to be two things at play:

  1. It seems like n8n crashed at some point and so the webhook did not get unregistered correctly. So does n8n check on start up if that webhook with the ID still exists.

  2. That check fails. Which is correct and expected but apparently did the error-message format change (probably from the underlying library) and so it does not catch it correctly. That problem will be fixed with the next version.

So the best thing for you to fix that problem now would be to save the workflow under a new name and activate that one. As soon as you did that, delete the old one. All should then work fine.

Got it, thank you :wink:

Fix got released with [email protected]