Succeeded in invalid value

Hi there,
After database migration to postgres, “Succeeded in” displays incorrect values

Hi @Valdri :wave: Sorry to hear this happened to you!

Just to make sure we’ve got the information we need, what database type were you migrating from over to Postgres?

Were you also updating n8n at the same time? Do you have any logs or commands you used when you were migrating just so we know what happened during the process?

Could you also let us know the following:

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Just to make sure we’ve got the information we need, what database type were you migrating from over to Postgres?

I migrated from sqlite to postgres

Were you also updating n8n at the same time?

I have not updated the n8n version

Do you have any logs or commands you used when you were migrating just so we know what happened during the process?

I used n8n cli

n8n version: 0.236.3
Database: postgres
n8n EXECUTIONS_PROCESS: default
Running n8n via: Docker
Operating system: Debian 11

I checked the values in the execution_entity table

This looks like a time zone problem
startedAt saves in my local time zone(UTC +2) and stoppedAt saves in UTC

Thanks for that information, and great catch - in Docker, is your docker-compose setting a timezone? Does this timezone match the timezone you’ve set for both your OS and your n8n instance as well?

My system timezone CEST +0200
in n8n docker-compose I have GENERIC_TIMEZONE=Europe/Warsaw

I ran the date command on the host and in the docker
image

Hey @Valdri,

Can you also set the TZ option for n8n and make sure the database is configured to use the correct timezone, This is one of those issues where the timezones are getting mixed up somewhere.

1 Like

Hi,
I recently upgraded n8n to version 1.1.1 and switched EXECUTIONS_MODE to queue.
Now Succeeded in displays valid values.

1 Like

@Valdri are you using queue mode? if you only have one instance of n8n running setting it to queue mode might cause some issues.

1 Like

@Jon I have 1 main n8n instance and 2 workers

Hey @Valdri,

That is interesting, If you have 1 main instance and 2 workers why did you not already have the executions mode set correctly? It might be worth checking your configuration again for any other issues as that is a pretty big one if you are wanting to use queue mode.

Hi,
I think we have misunderstood
When I started this problem, I had 1 main n8n node in version 0.236.3 without any workers with default EXECUTIONS_PROCESS
And with this configuration I had this issue.
Yesterday I updated n8n man node to version 1.1.1, changed EXECUTIONS_MODE to queue and added 2 workers.
And after that the problem resolved itself.

Hey @Valdri,

That makes sense but shouldn’t have fixed the issue so I suspect something else changed at the same time.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.