SuiteCRM Integration

Hey, first of all, thanks for the share.

I can use the module fine for get, so I assume the credentials and the .htaccess work. In the module-dropdown I get a list of “nullmodule.”, when I select one though, it gets update to “Contacts” or whatever it happens to be. (happens with both the trigger and the node)

The trigger does not work:
There was a problem and the workflow could not be activated:
Cannot read property ‘detail’ of undefined

And then the webhook with id xyz already exists.

SuiteCRM 7.11, API User with Sysadmin privileges
module from the link installed (but I did not configure anything, are there docs ?)
n8n 0.74
n8n-nodes-suitecrm 1.0.1

Does any1 of you have a hint how I can make it work?

as for the module wh i would uninstall and install it i have no idea what the problem is. The dropdown menu with “null module” I think depends on the version of php on the suitecrm site because before it worked well and listed all the modules but after I updated the php I don’t remember what I did. Checking I no longer have the .htaccess file I don’t know why. I solved all the problems I had before by reinstalling n8n and n8n-node-suitecrm. now i have the “null module” problem but it works perfectly

1 Like

I have PHP Version 7.3.20. I can’t reinstall n8n and it has worked perfectly for months. Re-Installed n8n-node-suitecrm but does not solve. Good to know that you have null module problem too and it works! Maybe one of the developers will be able to fix it

1 Like

After installing the webhook module in SuiteCRM I corrected permissions and ran Quick Repair and Rebuild: The Quick Repair and Rebuild creates the table in the SuiteCRM database (which the installation itself did not do in my case). The null module error persists but I dont mind very much.

Great feature with before and after dataset, brilliant.

Thanks for your help marconte

1 Like

I think the “null module” problem is due to the configuration of the genericfunction.js file in the node_modules / n8n-nodes-suitecrm / dist / nodes / SuiteCRM folder and in the async function getModules () function {
const returnData = [];
let modules;
try {
const endpoint = ‘/ meta / modules’;

will it be / meta / modules?
I hope it at least works like me. good job

Hi @marconte,
Great to hear it worked for you at the end (sorry for didn’t response until now, I couldn’t find the time). I will check the “null module” issue and your solution and will update the package.

1 Like

Hi @svenjanssen,
Great to hear if worked out for you at the end. I will check the “null module” issue and @marconte solution and update

1 Like

so the null module problem is solved? but do I have to update the module on suitecrm right?

No - this is not yet fixed. I will check it when I will be available


i noticed that if you change the php from FCGId to fpm on apache server and php 7.3 you read all the modules, can it be useful?

Goodmorning everyone now everything is fine i have tested the module in every scenario, everything works but only when i use as trigger in delete davun me error that can’t find record id when delete field is one. the beauty that the record is, strange …

hi for node-suitecrm what is tested nodejs version?

I use it with Node 13, which is a non LTS Version (not a good one…)Try 12 or 14 better

Ok thanks very much

Also you can try to use our package with the trigger of the other package.

i have build a new module under studio in suitecrm but its not visible in list module

why? i understand

I installed the above module

npm -g install n8n ,
npm install n8n-nodes-suitecrm
when i start n8n, i look for the suitecrm trigger as some of you have in the pictures and its missing what am i doing wrong?

I installed the webhook module to suitecrm, but i dont see suitecrm anywhere in n8n???

try installing suitecrm globally too like so:
npm -g install n8n-nodes-suitecrm
restart n8n

thank you that works.