Taiga Auth Issues


I’m trying to connect to a local instance of Taiga. I can use the API just fine from Postman/terminal.

But when I try get all Issues using the Taiga node, I get:
{"name":"RequestError","message":"Error: connect ECONNREFUSED","cause":{"errno":-111,"code":"ECONNREFUSED","syscall":"connect","address":"","port":9000},"error":{"errno":-111,"code":"ECONNREFUSED","syscall":"connect","address":"","port":9000},"options":{"timeout":300000,"headers":{"Content-Type":"application/json"},"method":"POST","body":{"type":"normal","password":"root","username":"root"},"uri":"http://localhost:9000/api/v1/auth","json":true,"simple":true,"resolveWithFullResponse":false,"transform2xxOnly":false}}

Any advice is greatly appreciated.

Hey @theneilkirk!

May I know how are you running n8n and Taiga? Are you using docker for both?

Yes, both in Docker

Are they sharing the same network? To make sure Taiga is accessible, it has to be accessible by n8n. From the error message, it seems that n8n can’t access Taiga. If they’re running on different containers, you will have to create a network that will allow them to communicate.

1 Like

Gotcha. Looking into it now. Thank you!

Sorry to be asking Docker questions here… but I’ve tried to connect them myself and I’m not having any luck.

First, I tried using the default bridge. As taiga runs using docker-compose, followed these instructions to try get it to be added to the bridge:

When that didn’t work, I read the docker pages and created a user defined bridge:

Then, one by one, I connected the various Taiga containers: gateway_1, async_1, back_1, async-rabbitmq_1, front_1, protected_1, db_1

Each time I tried updating the URL in the to the IP address I found using docker network inspect mynet, e.g. but always got the ECONNREFUSED error.

My questions at the moment:

  1. Any clue as to which Taiga container will be the one to connect to?
  2. Do I need to use the full IPv4 address ( or as I’ve written above without the trailing slash?

Very sorry but sadly no idea which one is the correct one. That would be a question for the Taiga forum. But I guess Taiga is reachable via a public domain or IP address. You should be able to just use that one.

1 Like

Just trying my luck :slight_smile:

I’ll ask the Taiga crowd and post here if I find an answer!