Telegram Node problem with test webhook in the queue mode

Hello everyone!

The n8n is running in queue mode.
Part of the .env configuration:


There were problems with /get at https://api.n8nhost/test, but found a solution in the thread and added the line n8n_editor_base_url, after which the test webhooks began to work properly.

However, yesterday I discovered a problem when creating a telegram node.
In the web editor, the url of the test webhook appears like this:
CleanShot 2023-03-10 at 12.25.29

Nothing works, the trigger does not see the message (only if you do not go into production mode)
I decided to check webhook value via telegram api, and it looks like this:

CleanShot 2023-03-10 at 12.27.05

As a result, the telegram node pulls the webhook address from the webhook_url, but as mentioned in a neighboring thread, it will not work.

please advise, how can this problem be solved?

n8n Version 0.219.0
docker installation

Hey @brewoutlay,

So to make things a bit easier, What happens if you use a normal Webhook node? I can’t see the images properly of what the UI is displaying but I would expect the test URL to be https://app.n8nhost/test/xxxxx and the production url to be https://api.n8nhost/main/xxxx

So the question then is what part isn’t working, The main url would only be on the webhook workers so there could be a routing issue if you are redirecting them to the main instance and the test webhook should go to the main instance.

If you start with a webhook node it might be easier to debug and work out what is going on.

I’ve already figured it out.
The telegram node creates a wiretap of the test webhook at api.n8nhost/test instead of app.n8nhost/test.

Naturally, if i create a normal webhook, everything listens correctly and at the right address.

1 Like

Hasn’t anyone else encountered it?
I don’t want to change the webhook url back to app.n8nhost :frowning:

When you say it “creates a wiretap of the test webhook” what do you actually mean?

pls, read again my first msg…

  1. telegram node trigger - in web editor showing the app.n8nhost/test/adaszxczxc/webhook
    (screenshot 1)
  2. nothing works. i’m starting to check what node i actually installed in telegram
    (screenshot 2)
    https://api.n8nhost/test instead of https://app.n8nhost/test

normal webhooks work fine.
node telegram should create a webhook at the address app.n8nhost/test.

how else should i explain?

Hey @brewoutlay,

I read the first message, I couldn’t see the URLs in the image to work out what was being set. In theory a normal webhook should work the same way as the Telegram webhook unless the display value is correct and the webhook we send to Telegram is wrong for some reason.

Maybe that is what you were saying… If that is the case we would have to check the code for the node to check what we are sending.

Did this work on a previous version of n8n for you?

It worked correctly before I installed different webhook_url and editor_url.

Unfortunately there is no way to rollback the version to check, as on the same server constantly running several projects for users.

Let me attach more detailed screenshots:
(with hiding the real URL, of course)

  1. Telegram Trigger -
    Test URL: https://app.n8n/test/17de70d4-7914-4aa9-a64c-1b40d2a87470/webhook
    CleanShot 2023-03-10 at 18.57.50

After clicking on “Listen for test event”, I try to write a message to the bot, but nothing happens.

  1. Let’s check installed webhook in Telegram, by request to API at the address:
    CleanShot 2023-03-10 at 19.04.23

And there we see that the webhook URL:

It should be:

Now do you see what the problem is?

Hey @brewoutlay,

I do indeed, So it sounds like the issue might not be version related and instead linked to config, Out of interest what gets sent if you activate the workflow does that then use the correct address and everything works as expected?

I will do some local testing next week to see if I can find any internal issues with it.

Yes, when I activate it, everything works correctly.

I’ve tried replacing the telegram trigger with a webhook by myself by setting the address of this webhook in the telegram bot api - but having any other telegram module in the workflow automatically changes the url of this webhook to incorrect again - when I start testing.

Perfect so I guess the good news here is it is only an issue for testing and not actually impacting the workflow as such.

I will let you know what I find in the node.

Thank you, I’ll be waiting.

I will also try to deploy a configuration identical to mine on a separate server - and test there.

Because I’m sure that the problem only occurs in the queue configuration and with separate url for webhook and editor.

1 Like

Hi. Have you been able to test it?

Not yet, We don’t typically work weekends and I have had some catch up today on support requests from over the weekend.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.