The Let's Encrypt SSL certificate is not installed

Hi. I install n8 according to the instructions Docker Compose | n8n Docs.

The problem is that the SSL certificate is not installed. What could be the problem?

root@1867117-cq80959:~# sudo docker compose up
[+] Running 2/0
 āœ” Container root-n8n-1      Created                                       0.0s
 āœ” Container root-traefik-1  Created                                       0.0s
Attaching to root-n8n-1, root-traefik-1
root-traefik-1  | time="2023-08-20T11:58:29Z" level=info msg="Configuration loaded from flags."
root-n8n-1      | n8n ready on 0.0.0.0, port 5678
root-n8n-1      | Initializing n8n process
root-n8n-1      | Version: 1.1.1
root-n8n-1      |
root-n8n-1      | Editor is now accessible via:
root-n8n-1      | https://n8n.skabitchevskiy.ru:5678/
root-n8n-1      |
root-traefik-1  | time="2023-08-20T11:58:40Z" level=error msg="Unable to obtain ACME certificate for domains \"n8n.skabitchevskiy.ru\": unable to generate a certificate for the domains [n8n.skabitchevskiy.ru]: error: one or more domains had a problem:\n[n8n.skabitchevskiy.ru] acme: error: 400 :: urn:ietf:params:acme:error:tls :: 2a03:6f00:6:1::517:3238: remote error: tls: no application protocol\n" providerName=mytlschallenge.acme routerName=n8n@docker rule="Host(`n8n.skabitchevskiy.ru`)" ACME CA="https://acme-v02.api.letsencrypt.org/directory"

Information on your n8n setup

  • n8n version: 1.1.1
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker-Compose
  • Operating system: Ubuntu 22.04

The problem was in the AAAA recording. I deleted it and everything worked.

1 Like

Hey @Danilov_Vovka,

Looks like Lets Encrypt has returned the error below:

unable to generate a certificate for the domains [n8n.skabitchevskiy.ru]: error: one or more domains had a problem:\n[n8n.skabitchevskiy.ru]

Looking at the site you have it sorted now though and you are seeing a safe search block instead.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.