TheHive Trigger not working properly

Hi n8n community !
I am coming here because I’m facing an issue I can’t manage to solve by myself.

Issue description

The node ‘TheHive Trigger’, which is supposed to execute when some webhooks are fired, is not reliable.
Here is the node I’m talking about :

Indeed, when I put ‘*’ as Event Types, which is supposed to trigger for all events, it doesn’t execute :slight_smile:

What I tried

  • The workflow doesn’t execute when an event is supposed to arrive in n8n.
  • The workflow isn’t appearing in executions, even if it’s set to “active”.
  • I thought it might not be displayed on executions but still work, so I tried to ping a URL in the workflow. The URL is never accessed from my workflow :

Example of simple workflow

(Seems the node is not existing on this forum preview)

Information on your n8n setup

  • n8n version : 0.202.1
  • Database you’re using (default: SQLite) : PostgreSQL
  • Running n8n with the execution process : Own
  • Running n8n via : Docker

Hi @Gwendal, I am sorry to hear you’re having trouble. Does this node work for specific events for you and just fails when using the wild card option? Or is not working regardless of the event type you select?

If it’s the latter, could you check whether your webhook URLs are correct and are reachable from your TheHive instance? When manually executing the trigger node or activating your workflow, n8n would register a webhook with TheHive, which doesn’t seem to arrive in your case.

It might also be worth checking if TheHive has any logs that help understand what exactly fails for you. Unfortunately, the respective section in their documentation seems blank so I am not quite sure if such logs exist in the first place :frowning:

Hi @MutedJam, thanks for your quick answer.

Unfortunately, this node fails for all event types I select. That being said, it ‘sometimes’ works with the wildcard option.

Is there any limitation in case I have 2 different active workflows with the wildcard option, that would lead to executing only one of them ?

Hm, not sure why it would sometimes work - this would typically suggest a network problem if some webhooks arrive and others don’t. At this stage you might want to check in the source system (TheHive) what happened with each webhook sent to the trigger URL provided by n8n.