'Trigger' related 'silent' Bug after update to 0.180.0

Describe the issue/error/question

I have a bunch of workflows that use Cron trigger and run at, specifically, the 59th minute of every hour.

On the first occurrence of the 59th minute, after updating to 0.180.0 from 0.179.0, only 1 of these workflows fired.
On checking the docker container logs, there isn’t even an entry for any of the other workflows.
It seems that only one of the Cron nodes worked, while the other nodes (Cron nodes in the other workflows) never received any trigger. They didn’t reflect in Console logs or the Execution logs.

To investigate further, i created a test workflow:

Cron that runs every minute.

This is the execution log for that:

2 issues here:

  1. The execution id 748751 should have run succesfully.
  2. The execution got skipped for several minutes [b/w execution ids 748748 - 748751 and again b/w 748756 - 748759], even though it’s expected to run every minute.

Also, there’s been no change in the server performance during this time. The charts for the past few minutes:

Now, i’ve not had the opportunity to inspect the remaining trigger based workflows yet, but my preliminary observation is that a lot of trigger-based workflows that are activated, are not firing at all.

Information on your n8n setup

  • n8n version: 0.180.0
  • Database you’re using (default: SQLite): Postgres
  • Running n8n with the execution process [own(default), main]: main
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Also, don't know if (& how) it's related or not, but my docker build usually takes a few (3-5) minutes. But this time, it took almost 45 minutes to build.

Hi @shrey-42, I am so sorry to hear you’re having trouble. I am currently trying to reproduce this myself and have also flagged this with the team.

So after the first 10 minutes I can’t see any issues on my end following the upgrade to [email protected]:

My other workflows are also running fine so far, without any trigger problems. How long did you have to wait before the problem came up?

Did you perhaps change anything else apart from upgrading? Any docker operations causing your container to temporarily stop? Any network problems that could have prevented execution data from being persisted to the database?

Didn’t do anything different from what i do everytime.

sudo apt update && sudo apt upgrade
docker-compose pull
docker build
docker-compose down && docker-compose up -d

The issue started almost immediately, with some of the trigger-based workflows not running.
The issue with the ‘Every minute CRON’ started after 10 minutes.

Don’t yet know how to debug docker itself, for possible issues.

The container does restart automatically, but not in-line with the gap in the CRON execution.
(n8n instance restart trigger sends the log)

The network for the Droplet seems ok.

Hm, still no problem here I am afraid :frowning:

Let’s see if the engineering team has any ideas as to what might cause this on your end.

I’ve also rolled back to 0.179.0 and going to run tests for the next couple of hours.
Will see if there’s any change.

Can confirm, after rolling back to 0.179.0 and after an hour of continuous testing, everything seems be working properly.