Triggers not working on self hosted instance?

Hello there,

I just discover n8n product, and it’s such a good product to automate many tasks !

As a technical profile in my company, I want to self host n8n on our specific machine using docker, very easy by using the tutorials, and my instance works perfectly (actions works)

But when I want to use the triggers (I try typeform and ActiveCampaign triggers), nothing happend (seems the triggers doesn’t detect that the action has been performed)

To be sure that the issue isn’t from the plugin, I try on n8n cloud and it’s works perfectly. Maybe there is a missing configuration to make it works ?

Anybody encoutered the same issue or not ?

Thanks for your help,



Hi @Florian_Ruen

Welcome to the n8n community :tada:

When you’re self-hosting in the local machine. There is no way for n8n to get data from the outside world.
Here is where the Tunnel comes in.

Tunnel lets you get data from the other applications. You can refer to the below documentation to enable it.

Please note that n8n Tunnel is only for testing and development purposes. Don’t use it in production. (Since it can be accessed by anyone with the tunnel URL)

If you’re hosting in the VPS like Digital Ocean, Make sure you have WEBHOOK_TUNNEL_URL set to your n8n instance domain name in the enviroment variables.

Please mention how you’re hosting n8n. (Docker, Desktop App, npm)


Hi @mcnaveen ,

Thanks for your answer !

I host n8n using docker-compose on AWS EC2 machine, but I found the issue yestarday evening.
The issue was caused by a not valid SSL certificate (because I run the docker before the DNS propogate so the Let’s encrypt validation failed)

Right now it’s fixed, but thanks for the tips about the tunnel !

PS : Now I’m confronted to another issue related to Scope Error using Hubspot Trigger - #24 by MutedJam


1 Like

Thank you!! you saved my day!

1 Like

Happy to see my answer helped to solve your issue :relaxed: