Trouble with n8n on MacOS

Hi everyone!

I’m reaching out because I’m having trouble installing n8n globally using npm. I’m following these instructions but have not been able to successfully run n8n or n8n start. The terminal keeps on telling me that “n8n is not found”

Here’s an image of the error logs

I also looked at this GitHub repo for more information on macOS and node but have failed to get n8n working through npm installation after following the steps to reinstall xcode, etc.

Could someone help me throughout the process or let me know what I’m missing? Thank you in advanced.

Welcome to the community @diane!

Did you try with the latest version (as the date displayed in the image is yesterday)? Because in the latest version [email protected] did we remove the dependency to mmmagic which seems to make problems for you. So the chance is good that the latest version simply works now.

Thank you Jan! After reading your comment, I was able to run n8n after the npm installation. I appreciate your help and look forward to exploring n8n more!

Really great to hear that it works now for you! Have fun with n8n!