Troubles with HTTP Request Object

First off… I love n8n – it’s a fantastic product.

I’ve recently been trying to get an instance stood up and I keep running into an issue where the service instance will essentially hang when attempting to perform an HTTP request.

Ways I’ve tried to deploy and their outcome:

  • Local Windows Desktop App - Works perfectly
  • Azure App Service - Works perfectly; save for some storage issues which I’m not going to bother with yet
  • Azure Ubuntu Host + Docker container - Using the exact instance creation parameters in the n8n docs, the instance loads fine but I cannot execute HTTP Requests (No response, UI fails connection to n8n backend)
  • Azure Debian Host + Docker container - Same as above
  • TrueNAS + Ubuntu Host + Docker container - Same as above
  • Debian Buster + npm install - Same as above
  • Ubuntu 20LTS + npm install - Same as above

Usually at this point, I’ve pinpointed the problem and worked around it but I’m currently no closer to understanding what’s failing.

Setting n8n debug doesn’t provide much either. The only message I get from n8n is when I try to stop the hung workflow:

ERROR RESPONSE ResponseError: Execution not found at /usr/lib/node_modules/n8n/dist/src/Server.js:1368:23 at async /usr/lib/node_modules/n8n/dist/src/ResponseHelper.js:90:26 { httpStatusCode: 404 }

Please tell me I’m an idiot and what I missed… I really did attempt to not bother the community but I’d really like to get this operational.

Thanks y’all!

Hi @cb1kr, welcome to the community!

I am sorry to hear you’re having trouble. Based on your description I suspect your instance might have quietly died while performing your request :frowning_face:. So let’s try to figure out what happened here. Could you share your workflow and confirm which version of n8n exactly you are using?

Also, when executing it, can you take a look at the server logs during your workflow execution and check for any errors? You might want to consider setting your log level to debug beforehand.

Here is the workflow, it’s got nothing to fail:

This is v. 0.191.0 in all cases.

I will enable debug, but console doesn’t show more than I posted above when I try to stop the workflow.

You’re quite right, this looks pretty much straightforward and actually works fine when I tested this just now:

So let’s see if your server logs contain any additional clue :slight_smile:

…like I said. Works flawlessly in two cases (Azure App Service and local desktop install) which makes this problem so weird!

As for logs, can you please specify specific locations/logs that I can post? I’ll set debug and upload the file, but if there are additional locations to look, please let me know.

So I don’t know which errors is happening here, but there shouldn’t be that many server log entries when running a workflow. On docker you can view them in real time by running the docker logs n8n --follow command (where n8n is your container name).

In the scenarios where this isn’t working for you, are you using some kind of reverse proxy or any other service processing the network traffic between your browser and n8n?