Trying to upload attachments from Gmail to S3


I am testing new Gmail Integration via OAuth2 with s3.

Currently, I have this workflow

This workflow gets all emails with attachments from my Gmail account (with resolved method, that includes all email details as well as attachments) and try to upload them to s3, as you can see here:

The problem is that I am not sure how to define where is located binary data of attachments on s3 step at these fields:

Does anybody test it properly?


Does it only have to work for one attachment or also for multiple ones?

Hi Jan,

Currently, every email has just one attachment and multiple emails can be recovered at the same time.

In this case it is easy as you would have to only set “Binary Property”, which is currently set to “data”, to “attachment_0”. Then everything should work fine.

I am trying this

and I get


@RicardoE105 as you are the one which created the S3-Node do you know what the problem could be here? Maybe you saw it before. But sounds like a bug.

@jan will check this out today.

1 Like

@Miquel_Colomer checked this and it works fine for me. I wonder if you set up any of the additional fields on the S3 node? If so could you please let me know which ones you set?

Not sure why, but now it copies attachments to folder :sweat_smile:

Now, after starting workflow, s3 never ends (loading gif appears always)

Additionally, OAuth2 session is lost and must be reconnected manually.

Can you share that workflow with me?

Now workflow works. I think it is related to network latency problems.
If I detect the same issue again, I will notify you.

Ah great to hear that it works now!

Yes, please keep us updated if you have issues again.

I’ve got same error 400 again:
ERROR: AWS error response [400]: 400 - "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\nXAmzContentSHA256MismatchThe provided ‘x-amz-content-sha256’ header does not match what was computed.

I share my workflow:
Workflow to upload attachments to s3

Is it dependent on the file or file-type? Or did it not work with a specific file before and then suddenly started working?

Perhaps this helps you:

  1. Gmail recovers up to 8 different emails.
  2. Every email has only one attachment.
  3. First attachment/email is uploaded properly to S3.
  4. Second attachment/email returns commented failure on s3 node.