Twitter Node failing if link in tweet

I just updated to 0.148.0, removed the N8N_USE_DEPRECATED_REQUEST_LIB=true flag from my docker run and the issue is still present.

Reverted back to 0.139.0, then pulled latest again, this time tests show issue is resolved.

Hi @hellotimking

Just making sure, so it means it’s working fine with version 0.148.0 without using N8N_USE_DEPRECATED_REQUEST_LIB=true right?


Without the flag set true it works perfectly in 0.148.0

1 Like

Amazing news!

Glad it’s solved! Have fun automating :grin:

I am on version 0.150.0 and encounter the same issue. In fact, I receive a 403 error with and without a link in the body of the tweet. I double-checked my API key credentials and made sure its permissions are set correctly.

Any hints on what could be wrong?

Hi @pkastner, and welcome to the community :tada:

I’m very sorry to hear you’re having issues with sending Tweets through n8n. The behaviour might not be related to the problem reported in this thread though. Using Twitter with n8n version 0.150.0 also works fine in principle (this masterpiece of a Tweet was sent out to test this just the other day :wink:).

Would you be able to share a workflow using which your problem can be reproduced and also confirm if you have any environment variables set? Maybe post this is in a new topic to make sure your question doesn’t get overlooked.

I have the same issue. Did you resolve it?

Hi @mmkilinski, judging purely from the error code 403 received from Twitter, this could be a problem with your Twitter API credentials. Did you follow the steps from the documentation to obtain your credentials?

Yes, I’ve made every step from the documentation. I’ve successfully connected to Twitter account but I can’t use API.

1 Like

Hey @mmkilinski

From your last screenshot we can read the reason the request is failing:

You currently have Essential access which includes access to Twitter API v2 endpoints only. If you need access to this endpoint, you'll need to apply for Elevated access via the Developer Portal.

There is also a link to “Learn more” and possibly solve the error.

1 Like

I don’t understand. I’ve made all steps from the documentation. There is no mention of applying for Elevated access there.

Hi @mmkilinski, this appears to be a fairly recent change by Twitter as per their blog:

So we will need to update our documentation on the Twitter credentials (and possibly also the Twitter node itself in order to utilize their API v2 at some point). For now, you might want to follow the Twitter developer documentation to get the respective access level. As suggested by @krynble, I’d start with the link they provide in their error message:

Ok, it makes sense. The n8n Twitter flow uses APIv1.1 I guess.

1 Like

Exactly, the node is currently using 1.1 endpoints (which before the aforementioned change were the default endpoints available to all developers, but now require additional steps in the Twitter approval process):

So thanks a million for your detailed screenshots and explanation, these helped greatly with understanding what was happening here (and also explain why other users did not run into the issue if they had set up their Twitter developer accounts before 15 November).

I’ve blocked an hour before the weekend to update our documentation accordingly.

1 Like

I can confirm that the problem is resolved with elevated access! However, it’s still possible to send tweets via the v2 API without elevated access, I tested with Postman (my account was created after Nov 15). I suppose changing the endpoints might be the better way to go as opposed to having everyone go through the approval process?

Yes, moving to Twitter’s v2 API would definitely be the preferred solution. I have added it to our backlog :slight_smile:

Hi @mmkilinski and @pkastner, I was looking into updating our documentation today (Friday was unfortunately a lot busier than expected), but I can see it already suggests using standalone apps. In the Twitter developer portal these would automatically be created with v1.1 access for me:


Could you confirm whether you have generated your credentials using this option or did you by any chance use a “Project” (which Twitter heavily pushes as the new default option)? Or in other words, when navigating to, in which section would your Twitter app for n8n appear?

@MutedJam I used the “Project” method which was the only one I could see in my dev portal. Worked well for me after receiving elevated credentials.

1 Like

Unfortunately, I don’t have this Standalone Apps option. I’ve made the Developer account after the 15th of November, maybe because of that.

1 Like