Unable to Add Google Tasks Authorization

Describe the problem/error/question

A couple of days ago I updated the N8N version, but in the process deleted all the data. I have than imported a couple of main flows which use Notion and Trello credentials, and everything worked just fine.

Today I tried adding a new credential for Google Tasks but when I enter ID and secret and try to click “Sign in with Google” I get an error:


I have tested other Google credentials, and they all fail with the same error.

Information on your n8n setup

  • n8n version: 1.3.1
  • Database: default: SQLite
  • n8n EXECUTIONS_PROCESS setting: default: own, main
  • Running n8n via: docker
  • Operating system: Raspberry Pi OS

Hi @Nejc :wave: Sorry you’re running into this!

This is an issue our engineers are aware of, and a fix for it should be included in the next release. In the meantime, the only potential solution I’ve been made aware of is if you click “save” for the credentials before you click “connect/sign in with Google”, that can fix this up - the workaround helped me out just there when I was reproducing the issue, so hopefully this will also suit you in the meantime :slight_smile: Otherwise, it should be fixed up shortly.


Thank you very much for the reply!
Apologize if I have missed already opened topic regarding this issue.

1 Like

You didn’t, @Nejc , I just wanted you to know it’s definitely on the to-do list :smiley:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.