Unable to connect to Redis from n8n Docker container

I run both n8n and redis as Docker containers on a single CapRover instance. CapRover uses Docker Swarm as orchestrator, and as far as I understand the containers are all visible one to another because they belong to the same Docker network: captain-overlay-network.

CapRover allows the deployment of one-click apps, that are basically Docker images with some additional configuration for Nginx. This is the one-click app for Redis:

And this is how I configured the Redis credentials in n8n:

With this setup the redis node in n8n doesn’t seem to connect and the spinner keeps spinning. I don’t see any errors in the UI.

I also tried to replace Host with localhost and, but with no avail. I think I have the same Docker issue described here.

If I configure port mapping on the Redis container (from the CapRover UI) and I run n8n start from my laptop (without Docker) I can connect without any issue. E.g. here I’m using Redis Desktop Manager.


Welcome to the community @jackdbd!

Sorry, can sadly not help you here as it sounds like something the CapRover community should be able to help you. If it does not connect, the reason would be that n8n can not reach redis.

Hey @jackdbd

I got this to work with a setup very similar to yours. Feel free to PM me so we can work on a solution, and then we can update this thread accordingly for others facing the same issue.

1 Like