Unable to create case in thehive

Unable to create case in TheHive from n8n

Using exact parameters, the case can be created from CURL api
Attached Screenshots


What is the error message (if any)?

No error. Just no response.
No Input received at TheHive (checked the logs)

Please share the workflow

{
  "nodes": [
    {
      "parameters": {},
      "name": "Start",
      "type": "n8n-nodes-base.start",
      "typeVersion": 1,
      "position": [
        240,
        300
      ]
    },
    {
      "parameters": {
        "resource": "case",
        "operation": "create",
        "title": "n8n_test",
        "description": "n8n_test",
        "owner": "user1",
        "tags": "n8n_test",
        "jsonParameters": "true update",
        "options": {}
      },
      "name": "TheHive",
      "type": "n8n-nodes-base.theHive",
      "typeVersion": 1,
      "position": [
        460,
        300
      ],
      "credentials": {
        "theHiveApi": {
          "id": "1",
          "name": "The Hive account"
        }
      }
    }
  ],
  "connections": {
    "Start": {
      "main": [
        [
          {
            "node": "TheHive",
            "type": "main",
            "index": 0
          }
        ]
      ]
    }
  }
}

Information on your n8n setup

  • n8n version: => 0.156.0
  • Database you’re using (default: SQLite): => postgresdb
  • Running n8n with the execution process [own(default), main]: => own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: => Docker based on below docker-compose

Are you sure that thehive is reachable by n8n the way you try to connect to it? Because I assume it can not, at least that would explain what you are describing.

hi, yes it is reachable. I’ve tested using curl from the same host.
Also while putting the “developer tools” in Chrome, no call is being made from n8n module.

The same host does in this case sadly not matter, as n8n runs in a docker container that may or may not have access to the same resources and may or may not be able to access those via the same IP addresses or domains.

Did you actually go in the docker container and try from there?

When you say in Chrome. Do you mean the n8n frontend does not make any call at all to the n8n backend? Can honestly not imagine that. Did you try with the most simple workflow? An empty workflow that just contains the Hive node and execute that single node?

I did try from a standalone n8n (desktop app) to the docker hive and it worked. The only difference is the n8n desktop uses sqllite. So let me amend the docker config to discard POSTGRES and try with native sqlite

SQLite is 100% not what caused the problem. I am still pretty sure it is what I described above, Docker and the network setup.

thanks jan. The hint to try out from the docker-container made me to rethink of how n8n may call within a container.
I modified the network to “bridge” and made the call using the ‘container’ name

  n8n:
    image: n8nio/n8n
    container_name: n8n
...
    ports:
      - '0.0.0.0:5678:5678'
    networks:
      - hp_network

  thehive:
    image: 'thehiveproject/thehive4:latest'
    container_name: 'thehive4'
    ports:
      - '0.0.0.0:9000:9000'
...
    networks:
      - hp_network

networks:
  hp_network:
    driver: bridge

so this time, i made the call in n8n using the container name & port http://thehive4:9000 rather than the external ip and it worked. Thanks again for your guidance

Glad to hear that you could figure it out. Have fun!