Unable to Setup n8n API Connection

I am trying to set up a workflow to check if a particular webhook is responding as a health check. If the webhook is unresponsive, I want it to turn it off and back on again. I have created an API key in n8n, but when I enter the key into the credentials for my n8n account, I get this error. This is a self-hosted ECS cluster in queue mode.

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: v0.221.2
  • Database you’re using: Aurora MySQL on AWS RDS
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker with AWS ECS

I’m experiencing the exact same issue with my self-hosted instance on Digital Ocean. Unfortunately, I haven’t found a resolution yet.

I’m attempting to integrate the backup to GitHub workflow, which includes the n8n Node with the API.

Here’s what I’ve done so far:

  1. Checked and updated the N8N instance: I’m running this on Digital Ocean, and I’ve downloaded the latest Docker update.
  2. Restarted the N8N instance: I’ve tried restarting the N8N instance by stopping it and starting it again, hoping that this might resolve the problem.
  3. Checked the network settings: I’ve looked into the network settings on the N8N instance, considering that they might be causing the issue. I’ve ensured that the network settings are configured correctly.

Could this issue be related to firewalls?

One thing I noticed is that I upgraded to version 0.222.0, but the settings section still displays Version 0.221.2.


Hi folks, this sounds like n8n might not be able to resolve the URL you are using. Seeing you are running n8n in a docker container, perhaps you want to try using a URL of http://localhost:5678/api/v1?

This should be a way for n8n to talk to itself (even if the public URL exposed to the internet differs), provided you set any environment variables telling n8n to do something else:

1 Like

Wow! That seems to have done it.

Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.