Unexpected Behavior of HTTP Request Node After n8n Update

Hello,

I recently updated n8n from version 1.4.x to 1.8.2. After the update, I noticed some unexpected behavior. Specifically, when I manually executed a workflow, the HTTP Request node, which should have run only once, executed thousands of times within 10 minutes. This issue ceased after some time had passed post-update. It’s worth noting that all the workflows I had created at that time were set to ‘Inactive’, and I was using the Schedule Trigger for the trigger node. Is this phenomenon related to n8n’s specifications, or could there be another underlying cause?

Information on your n8n setup

  • n8n version: 1.4.x → 1.8.2
  • Running n8n via (n8n cloud):

Hi @atososon :wave: Welcome to the community :tada:

Could you share the workflow that was the culprit in this?

Also, it doesn’t look like there’s a n8n cloud account associated with this email address. I’d be happy to dig into this deeper for you if you could DM me either your cloud account username or email :+1:

Hello @EmeraldHerald,

Thank you for your response. Here are the details of the workflow. The username and email address for the cloud account are as provided in our previous DM. I appreciate your assistance.

Best regards

Could you please share the actual workflow (select the nodes, copy them, paste them into here). Only like that will we be able to really understand what is going on there.

Generally, it looks like the last HTTP Request node would execute once for each row in the CSV file. If the CSV file has thousands of rows, then it would execute thousands of times and that is exactly what n8n is supposed to do. If you want it to execute only once, no matter how many items there are, make sure to activate the setting “Execute Once” in the node settings.

1 Like

Here’s the actual workflow I’m using. Please note that I’ve omitted any service-specific URLs and Body information for security reasons. Within the Repeated node, I am not using the CSV; it’s utilized in the subsequent nodes. While most nodes, except for the trigger node and the final HTTP Request node, are not directly related to the issue, I’ve included them here for reference. The entire workflow is quite extensive, so I’ve only provided up to the node (Repeated node) where the issue occurred.

Hi @atososon :wave: I’m not too sure based on that workflow with the last node not having too much data inside of it, can you try clicking here:

And then enabling this option:

And letting us know if that fixes it?

Whether I use the option you pointed out or not, the workflow operates without any issues. However, right after updating n8n, it executed an abnormal number of times, but now it’s running as expected. I reached out because I couldn’t identify the cause of this. It’s worth noting that I did not make any changes to the workflow I executed during this time.

Probably something changed in the csv you are reading with regards to number of items returned making it stand out more that there is a lot of executions of the http node resulting in a lot of items from that. :wink:

2 Likes

I have not made any changes to the contents of the CSV file. Are you saying that even if I’m not using the CSV file, the subsequent nodes are executed for each item in the CSV?

I don’t believe the implementation of the workflow is the cause. This is because it has been working without any issues in the past, and despite not making any changes to the CSV file or the content of the workflow, it only malfunctioned right after updating n8n.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.