Unexpected values error when trying to insert rows in snowflake table

Describe the issue/error/question

Hi ! I’m trying to create a workflow in which one of the steps is to insert a row in snowflake, based on data that is fetched in previous tasks.
The target table only have one column named ID

What is the error message (if any)?

I get an error coming from snowflake :

Please share the workflow


Share the output returned by the last node

I believe that I have not configured the node properly.
I tried to replace the value in the columns placeholder by the name of the column (id) : I don’t see any error but all values are null

Information on your n8n setup

  • n8n version: 0.190.0
  • Database you’re using (default: SQLite): Snowflake
  • **Running n8n via :**n8n.cloud

Hi @ThomasCouz, welcome to the community!

n8n uses JSON data under the hood, so the column name (which represents the key in a JSON object) would be case sensitive.

Could you try renaming the your ID column into id before you send data into Snowflake? You can do so via the Rename Keys node:

Your snowflake node should then find the id column:

Hey @MutedJam
Thanks for your quick reply !

So i added the rename key as suggested

But wen trying to execute the insert node I still get empty results :confused:

It seems that the column is found, but not the values of the rows

Hi @ThomasCouz, from looking at your screenshot it seems the data sent to Snowflake is coming from your Slack node which probably has a different data structure (not including an id field). What happens when you connect your Snowflake node directly to your Rename keys node instead?

1 Like

Indeeed @MutedJam you were right :slight_smile:

If anyone reading this, here is the workflow that works correctly :

Thanks !

1 Like

Glad to hear this does the job, thanks so much for confirming :slight_smile: