Update Google Sheets node: Could not find column for key

I want to update a Google sheet, but I am getting “ERROR: Could not find column for key “Submission ID”!”

The spreadsheet has a column “Submission ID” which I understand to be unique for each row:

I am using “Submission ID” as a Key in the node:

What am I missing?

Information on your n8n setup

  • n8n version: 0.198.2
  • Database you’re using (default: SQLite): default for desktpo
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: desktop Mac

May be a bug?

I decided to recreate / add a new Google sheets node instead of using a copied one from another workflow. I think it is identical as the one I had, but now it finds the key:

I will post the code here in case someone is interested in debugging:

Node that could not find the key:

Here is the node that works:

1 Like

Hi @fxholl, I am sorry to hear you had trouble with the Google Sheets node. It has been updated since n8n version 0.198.2 which you have in use, so hopefully this should no longer be problem :slight_smile:

@MutedJam I’m using n8n 0.205.0 & it still doesn’t have a place to place key field unfortunately. I’ve reverted to using the old node @fxholl provided above :frowning:

Is there a way it could be added under the “Append & Update” instead of just “Update” to minimize on the creation of unnecessary nodes/workflows - Thanks

Hey @KevinK, have you removed the old Google Sheets node from your workflow and added a new one? n8n wouldn’t change your existing workflow nodes, so you’ll need to add a fresh one to see the changes.

Yes I tried using the new Google Sheet node but it doesn’t have the “Keys” function that’s why I’ve reverted to typeversion:2 (old GS node version) I really need an identifier column seeing as I’m getting in values from a MySQL node

Could I be getting something wrong?
Here’s the New Node

and here’s the Old Node

i must be getting this same bug too
(note the picture has Update without any value. Tried update and upsert, with nanoId present and not)

Lookup is working fine

On the “Options” button at the bottom select “User Entered” & I believe that should do the trick

Still seem to get the same error.

Doesnt seem you clicked the link - 2 settings

Had tried all permutations of the selections from the Options menu

Can you screenshot your sheet columns and a couple of rows
Esp the nanoid

Thanks @treyr

I am stumped - only thing i would say is

  1. mock up a 2 node workflow and paste as a workflow here so I can try it in my instance
  2. change the fieldname nanold to something else - I know it is silly but i have seen silly things happen

The same exact setting is working for me every hour

@maja I think I found your problem.
I just built a new workflow and a new sheet and again I saw what you see - duplicates !!
I went to Google Sheets - selected all columns and made them all Text - no numbers nothing.
I am passing Strings from my set node and workflow and it seems to do a datatype match.

It worked !

See my set node - all Strings - made the sheets also

Wow nice work. Didn’t have the same success. Set all strings + also all Plain text and still the same error.

supported - new module search works incorrect with numeric values in columns.

Swap from numberic to string with set module - no success (and not converted to string
didn’t find (no errors) and Add new column

Result - append everytime, not updated at all

Old Module with Key and user entered works as expected but sad only update. Or new module if contains text (string) - works fine

Set module - string // shows as number:

Result - appended, not updated

Hi @lightcom, welcome to the community and please accept my sincere apologies for the trouble this causes. I was able to reproduce the problem and have added it to our engineering backlog for a fix.