Update to latest stopped working (n8n on pm2)

Hi!
Have been updating about once a month, and usually have no problems.
Running on AWS, lightsail, on Debian with PM2 and caddyserver.
V 0.179.0
Since the start I am running these versions. Always have worked fine.
npm 8.3.0
node 17.3.0

Suddenly I am getting this when trying to update. Please help!!
Normal process.
pm2 stop n8n
npm install -g [email protected] (here is where the error happens)
pm2 restart n8n

[email protected]:/home/admin# npm install -g [email protected]
npm ERR! code ENOENT
npm ERR! syscall spawn git
npm ERR! path git
npm ERR! errno -2
npm ERR! enoent An unknown git error occurred
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2022-06-29T02_44_28_959Z-debug-0.log

Regards,
Andres

Hey @pradilla,

Have you looked in the log file it mentions to see if it shows anything else? It could be worth trying it again to see if it was just a temporary issue.

Thanks @Jon , ran the process again today and went well this time! =)
regarding the log, sorry im no expert, can run nano xxxx/xxx/ and see it but too long so can really reach the bottom. Also tried to get it from the FTP server but cant get to the root/.n8n folder.
Regards,
Andres

That is good to hear, As a future little command for you… You can run less +G xxx/xxx to read a file from the bottom.

1 Like