Updating n8n

Describe the problem/error/question

I would like to update n8n self-hosted version

What is the error message (if any)?

I have run docker pull docker.n8n.io/n8nio/n8n

Then I ran docker ps -a

The following shows up

8ada887b15f0   caddy:latest   "caddy run --config …"   6 months ago   Up 6 months   0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:443->443/tcp, :::443->443/tcp, 443/udp, 2019/tcp   n8n-docker-caddy-caddy-1
c28cbcf9eb1b   fe1f1ad7fd19   "tini -- /docker-ent…"   6 months ago   Up 6 months   0.0.0.0:5678->5678/tcp, :::5678->5678/tcp                                                     n8n-docker-caddy-n8n-1

As per the instructions here: Docker | n8n Docs, I’m supposed to run the following

docker stop [container_id]

docker rm [container_id]

docker run --name=[container_name] [options] -d docker.n8n.io/n8nio/n8n

I don’t want to break anything so out of an abundance of caution, my question is given the above output in my terminal, which container should I stop using docker stop [container_id]?

Second, in this command: docker run --name=[container_name] [options] -d what is the options argument? Can I run the command without options argument?

Thank you in advance!

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Salami

Thanks for posting here and welcome to the community! :tada:

In your case the n8n container ID is c28cbcf9eb1b and the container name is n8n-docker-caddy-n8n-1.

So you can run docker stop c28cbcf9eb1b to stop your n8n container.

[options] refers to any configurations settings you need to set (e.g. environment variables, port mappings, volume mounts, etc.)

However, guessing from the name of your docker container you might actually have a docker compose file. Then it’s even a lot simpler. All you got left to do after your docker pull command, is to run docker compose down and then docker compose up

Done! :raised_hands:

@ria I’m very grateful for the quick response.

When I run docker compose down I get no configuration file provided: not found

How would I solve this problem?

I’m grateful in advance!

I just tried find / -name "docker-compose.yml" 2>/dev/null to search for the file across the system but there doesn’t seem to be one. :sweat_smile:

It’s there, if you have setup the n8n via this guide.

Hi

I tried to follow the steps but it didn’t work.

Here is what worked for me

  1. I located my n8n-docker-caddy by running: sudo find / -name n8n-docker-caddy
  2. I confirmed that I had a docker-compose.yml by running nano docker-compose.yml
  3. In the same folder I ran the following as seen here: Docker | n8n Docs
docker compose pull

docker compose down

docker compose up -d
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.