Upgrading from 0.184.0 breaks the Airtable trigger node

Describe the issue/error/question

After upgrading from 0.184.0, all of the workflows containing Airtable trigger nodes have errored out.
They can’t be activated anymore. Error shown below:

What is the error message (if any)?


Please share the workflow

Information on your n8n setup

  • n8n version: 0.185.0
  • Database you’re using (default: SQLite): Postgres
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hi @shrey-42, I am sorry to hear you’re having trouble here.

I just tried reproducing this but didn’t run into any trouble activating the Airtable trigger node on [email protected] (the only change made was me updating credentials, IDs and field names):

Can you confirm if there are any server-side errors when trying to activate your workflow? And does the problem persist if you delete the old trigger node and create a new one from scratch?

When i attempt to Fetch Test Event, i get this error:

NodeApiError: UNKNOWN ERROR - check the detailed error for more information
    at Object.apiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Airtable/GenericFunctions.js:27:15)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Object.apiRequestAllItems (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Airtable/GenericFunctions.js:39:24)
    at async Object.poll (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Airtable/AirtableTrigger.node.js:138:29)
    at async Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/src/Workflow.js:599:32)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:537:49

The Airtable main node is also not working.

And yes, the api key is working fine; checked it again in 0.184.0 as well as via Postman.

I think i found the issue.
I edited the credentials to now include 'Bearer ’ before the key. It works after that!

Looks like the credentials format has been changed post-0.184.0?

1 Like

That’s really odd, I didn’t have to do that for Airtable to work as expected. Anyway, really glad to hear you figured it out!

Didn’t see this anywhere in the Changelog or Breaking Changes.

No, and I didn’t have to make that change which is really odd. I wonder if this could be related to your custom n8n build.

Perhaps you can verify this behaviour against the standard docker image (docker run -it --rm -p 5678:5678 n8nio/n8n:0.186.0)?

Just tried this.
Same error.

Interesting, it’s happening for me as well with a completely fresh 0.186.0 instance (not with an existing 0.185.0 instance though). I’ll add this to our internal bug tracker for a closer look, thanks so much for bringing this up + for testing this!

Hi @shrey-42, a fix for the Airtable nodes has been released with version 0.186.1.