Urgent. Postgress credentials not working on version 0.231.3

Describe the problem/error/question

I updated from version 0.231.2 to version 0.231.3 and now the postgress credentials do not connect to my DB. This also happened on the version previos to 0.231.2 but was corrected in 0.231.2. Please help since this is my production enviorment and we depend on it.

What is the error message (if any)?

when you save the credentials setup is just keeps saving, never producing the green banner that says the connection is good. In the workflows that depend use postgress they just get a timeout error.

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

## Share the output returned by the last node
<!-- If you need help with data transformations, please also share your expected output. -->

## Information on your n8n setup
- I am now on the cloud version 0.233.1
database Postgres

Hi @gariva, I am sorry you’re having trouble.

I tried using your Postgres node on my own cloud instance running [email protected] but didn’t run into trouble here. I’ve then downgraded to [email protected], but the Postgres node is still working as it should for me. I tried connecting to multiple databases to be sure.

Is there a chance you are using an IP whitelist in a firewall in front of your database? If so, are you allowing all relevant IPs used by n8n cloud?

1 Like

HI, thanks for the prompt answer. Yes, we are using the whitelist. I will have to check that they included all of them. But I have never, several moths now, had any problem with this until this week end. On friday I woke up with the workflows failing. I updated the version to the latest stable and it worked. Today I woke up an saw the lastest stable had been upgraded and updated again. Thats when the problems started.

Is there a way to reboot the server so it gets a new ip?

I don’t think rebooting would achieve this as n8n cloud machines sit behind a NAT (meaning your database wouldn’t receive the request directly from the IP of the actual instance), but you can request a restart via the “Restart workspace” button on n8n.cloud.

The new IP was added around a month ago.

Which version of Postgres are you running exactly and where? I tried connecting to an Azure-hosted db (PostgreSQL 13.10) and a test database from ElephantSQL (PostgreSQL 11.18) which both worked fine.

Are you using any of the SSL settings in your credentials?

" The new IP was added around [a month ago]…That might be the problem.

We are running a postgres on Amazon RDS. engine version 11.16.

Already tried the restart workspace but as you mentioned it did not work.

I was afraid this wouldn’t help, but please do let me know once you’ve checked the IP whitelist on your end. You could also check the public IP of an instance using a workflow like below and match it against your rules:

In general, RDS should work fine with n8n, there are a few users here on the forum connecting n8n with a RDS database.

Thanks, I am checking the ip white list… this might take a while since I dont know how and are trying to reach the person who does. They will answer in a few. Will keep you updated.

Happy to say it is working now. Thanks for the help.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.