[User Management] How to invite users with SSL-less/unauthenticated SMTP server?

Hi @simon.lewis,

That is a shame, it looks like it is connecting and trying to send so it may not be an n8n issue. It is also possible that the request there is not from n8n when sending an invite email :man_shrugging:

For now I think the manual approach is going to be the way forward, I will check the internal ticket to see if there have been any updates.

As a temporary solution something like mailersend has a fairly good free tier that might get you by.

Thanks @Jon - I’ll keep nagging to see if we can get more info to pin this down.
For us, it is OK to work around as it only affects user invites. The Send Email node works fine.

Ultimately, our preference would probably be for shared access to administer all workflows so will keep an eye on potential future improvements to User Management (I see some comments on this across the forum).

Thanks again for the support and comments.

1 Like

so I am my server is using port 25 starttls enabled, what are my options? need to use send emails

For me this was the fix: Cannot get mails via IMAP - #5 by MutedJam
I did not know beside disabling SSL/TLS in config window I had to do this!

A related issue I have found is when using Google’s SMTP Relay service like my company. Since the relay service is setup to authenticate via IP no username/password authentication is required. From my testing N8N requires values to be set for the username and password variables in order for the Invite button to work. However, since Google’s SMTP Relay can be used with username/password authentication the relay fails if I don’t enter valid info for the username/password. It would be nice if the Username and Password variables for the SMTP were marked as Optional instead of Required.

Hello @Jon,
I’m having the same issue as described.
I was able to send email on node “Send Email”. I used it to debug.
On that node I’m able to send the e-mail when i select the option: Ignore SSL Issues
Before I was getting the same issue on Send Email node and N8N SMTP configurations.

Do we have the same option as environment variables for SMTP setup, something like : “N8N_SMTP_IGNORESSLISSUES”?

For SMTP configurations I just have the host and port 25.

N8N_EMAIL_MODE=smtp
N8N_SMTP_HOST=smpt.ourhost.com
N8N_SMTP_PORT=25
N8N_SMTP_USER=
N8N_SMTP_PASS=
N8N_SMTP_SSL=false
N8N_SMTP_SENDER=our-noreply-email

It works on Send Email node with “Ignore SSL Issues” option but not on on the environment variables. I don’t see Ignore SSL issues variable on documentation. Do we have something similar here?

Any suggestion?

Issue on send email without “Ignore SSL Issues”

Issue when try to send an invite using SMTP configuration on N8N:
image

Thank you!

Hey @abarreir,

We don’t have an option to ignore the SSL certs at the moment but… In 0.210.2 we have added an option to copy the invite link so it can be manually sent out.

image

It doesn’t solve the problem but maybe this will help.

New version [email protected] got released which includes the GitHub PR 9415.