userManagement json

Describe the issue/error/question

Currently i try to setup smtp with the json file:

	"protocol": "http",
	"host": "localhost",
	"listen_address": "",
	"port": 5678,
	"executions": {
		"process": "main",
		"saveDataOnSuccess": "all",
		"saveDataOnError": "all",
		"saveDataManualExecutions": true,
		"pruneData": true,
		"pruneDataMaxAge": 336,
		"pruneDataTimeout": 3600
	"generic": {
		"timezone": "Europe/Berlin"
	"userManagement": {
		"emails": {
			"mode": "smtp",
			"smtp": {
				"host": "some adresss",
				"port": 25,
				"secure": false,
				"auth": {
					"user": "",
					"pass": ""
				"sender": "n8n"

Yes user and pass should be empty.

What is the error message (if any)?

But it doesn’t work:

Information on your n8n setup

  • n8n version: 0.178.2
  • Database you’re using (default: SQLite): postgres (removed in the config file above
  • Running n8n with the execution process [own(default), main]: main
  • Running n8n via [Docker, npm,, desktop app]: npm

Hey @lublak,

I don’t think we support anon auth, If you pop in a username and password does it work? I think there could also be some issues around unencrypted mail servers that we have a dev ticket opened for as well.

Of course, the smpt server has no login data. Therefore this will not work.
But it works with Send Email:

Hey @lublak,

The node and the user management smtp setup is not the same thing.

By putting in credentials even if it doesn’t work it would confirm quickly if it is just where the field values are missing.

If I give the data (even if it is not correct) then it works.
But then of course I can’t send an e-mail.

That is perfect so it looks like the issue here could be where we don’t support anonymous authentication with the user management feature yet.

Is there a place to find all schema options for a JSON config file?


Give this a bash: n8n/schema.ts at master · n8n-io/n8n · GitHub

1 Like