Using previous airtable nodes to fill airtable create record fields

I have a workflow that receives a webhook via a button on Airtable. (The webhook provides, information of the baseid, relevant tableids, and recordid), then gets the record information, which includes some date fields. Later down the line, after some verification process, I want to create a record that links to the trigger record, of which should take some of the same data such as date, and some linked records. But I am unable to input either.

The linked records are simply unable to fill. (cursor turns into a :no_entry_sign: )

The date fields keeps returning an error “422 - {“error”:{“type”:“INVALID_VALUE_FOR_COLUMN”,“message”:“Field "Trial Date" cannot accept the provided value”}} - Field “Trial Date” cannot accept the provided value. Consider using ‘Typecast’ option”

Hey @Dennis_Yu

So there is a bit of a trick to this. I will explain it the best I can but I would advise you that you also google “Linking records with Airtable in N8N”
There is another post in the community that helped me solve this issue!

What you want to do is copy the node by highlighting the node and then using CTRL + C (On Windows) and then pasting that node into a text editor like VsCode or Notepad++.
You will end up with many lines of code like I have displayed below.
image

You will look for the field that you are trying to link and you want to change the “Read Only” from “True” to “False” as I have done in the Image above.

Also you want to make sure that the “typecast” option is set to “True”
Once you have done this, highlight all the code and use CTRL + C again to copy it and the CTRL + V to paste that node back into your canvas!

Once you fill the node back out again make sure that the typecast is set to True and you will be good to go!

P.S in your “Set” node I have found that you want to make sure you always set the record ID from airtable aswell just so you have it when you want to link back to it later in the workflow!

3 Likes

Okay. I was being silly, so having the typecast option on solves the problem with the time.
Perfect solution, thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.