Values of referred nodes are shown as NULL in the input (and workaround)

When I use a node to refer for a value, the value in the tip is null

It gets fixed when you change the node to the incoming the INPUT panel

This even persists in the Expression window:

Hey @artildo,

Have you tried using the newer $('Parsing') syntax?

@Jon Yeah, checked it. It persists. But anyway dragging gives the older expressions. If I want to do it in this way (with the same result), I have to manually alter the formula.

Hey @artildo,

Or update to 0.229.0 where this has been changed which I suspect will be marked as next today or tomorrow.

@Jon thank toy. By the way, there’s an opposite issue. Incoming data is marked as null when dealing with a more distant node:

Hey @artildo,

Which one one of those values is the one with the issue? There are 2 using $node.Webhook which could be empty if there are multiple input items to the node you are using and the $json[“domain”] could be empty because the item in the node before it doesn’t have it set.

Could you share more of the data so I can see what is happening just the small snip makes it very hard to work it out.

@Jon Oh sorry. I somehow suggested, that if I change a prop name in a Node, like from name to name_new, it will change everywhere it is referenced:
{{ $node['Set name1'] }}
{{ $node['Set name1'].json.name_new }}.

But it will not. So disregard my last message.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.