Webbhook error

Describe the problem/error/question

Out of nowhere, all of my workflows that use webhook started displaying this error. The webhook IDs are different and we haven’t made any changes in the last few days.

What is the error message (if any)?

Workflow could not be activated:

The URL path that the “Webhook” node uses is already taken. Please change it to something else.

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloud
  • Operating system:

Welcome to the community @danilo!

Sorry to hear that you have problems, but can you please review the information you provided underneath, “Information on your n8n setup”? Half of it is missing, and the other half honestly does not make much sense (you use n8n cloud with Postgres?). We will then do our best to help you. Thanks!

We are in version 0.212.1, we currently host it on heroku with a postgres database

Ah OK. So you self-host n8n.

Honestly do not have much experience with Heroku, but think it does some “interesting” stuff with turning the machines off if they are not used. Can imagine that this could cause some strange issues like potentially the one you described, triggers not firing, … . Generally probably not the best way to host an application like n8n. I would strongly recommend a proper virtual server which runs constantly.

This is not a problem for us, we pay for the plan that does not turn off the machines and our data flow does not allow the machine to turn off even if we use the free plan

We are currently losing a lot of data with this issue


We tried to restart heroku, but without success

We tried disabling and enabling everything again, but to no avail.

We tried to delete the webhook and create it again with another path, but without success

I was only able to save the workflow when I removed the webhook, but this is not possible in our case

Another thing that started to happen is that the only user is active and I am not able to create a workflow giving this error

Can you please share your configuration. Maybe that gives us some idea of what is going on here.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.