Webflow API Update -

The problem/error/question

Hello, i am working on my first workflow and running into problems. Everything is working except for Webflow.
My Webflow UPDATE fails. I am not clear if the required fields like name, slug, draft , archive, need to be in an update. Is there any way to view more detailed error output?

The error message

NodeApiError: Bad request - please check your parameters

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

The output returned by the last node

NodeApiError: Bad request - please check your parameters
    at Object.requestWithAuthentication (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/NodeExecuteFunctions.js:1039:19)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Webflow/Webflow.node.js:169:40)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:653:28)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:590:53

n8n setup

  • n8n version: Running version [email protected]
  • Database (default: SQLite): N/A
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Cloud
  • Operating system: Cloud

As a follow up, this is working for me if I turn off the “Live” setting. I’m not sure if there is a way to enable “Live” in the workflow. Is it possible to enable this setting?

Hi @rgreen, welcome to the community!

From reading this thread over in Webflow’s forum, it seems this is a limitation of their API:

(…) you need to do with the live = true param with ONLY the base required fields that the system assigns to the collection: In my case (standard CMS collection), that would mean: name, slug, _draft & _archived.

So you probably need to play a bit with your fields and remove some of them when using the Live option before this works.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.