Webflow optimizer : stuck on update item


I’m building a simple slug optimizer using GPT4.
I’m running into an issue when trying to update my item to webflow.

Here is the workflow:

Here is the result:

I tried removing the field and I still get the same error so I guess the issue must be broader than just updating the slug.

I have tried using API token as credential, and also oauth, both result in the same error.

Any help appreciated :slight_smile:
Thanks !

Hi @Joachim_Brindeau ! This is a pretty neat idea :smile:

Whilst testing this, I’m running into some interesting errors myself - out of curiosity, are you able to update any aspect of a post or collection that n8n has created through the actual Webflow UI itself? I’m not running into issues creating, but updating is another story :thinking: If you aren’t able to update the dataset in Webflow, unfortunately n8n would not be able to either - and it’s throwing a very similar error on the Webflow UI itself for me. Re-publishing the site as would usually be recommended is also not changing the results.

Just in case we’re missing something here, could you share the status of your dataset within Webflow?


I think can update on the webflow side no issue. I’ll try again tomorrow at work and will let you know ! Thank you !

Everything is published and whalesync updates records just fine.

1 Like


Still struggling to update absolutely anything in webflow.
Whalesync manages to do everything with my items.
I myself can do the changes in the UI.

However, whatever I try, it fails.

Hi @Joachim_Brindeau - sorry to hear you’re still having trouble with this!

I noticed you’re passing 101 values - perhaps one of these 101 items is using an an invalid value in any of the fields they are referencing in their Webflow node?

Can you try with one item at a time and see how that goes? For example, you could use a SplitInBatches node and run batches of 1, this should make it clear which item exactly causes the problem.

Webflow also seems to have some logic to their API that might be unexpected, take a look at this post as well to see if it might help. It might be worth checking with Webflow’s support team on what exactly is required of this request.

I tried with just one, and also noticed some field are set to required (not very clear in the N8N node, you notice it with you go through the list of fields).
I tried with just the one item and the required field only, still fails …

I will look into the post you gave me, thanks a lot.

NB: Live or not, it fails the same way.

My bad!

So I needed to add the required field and my last answer contains the wrong variable in the field “name”.
If I may suggest something, since slug, name, archived and draft are mandatory fields, they should be added next to the ItemID field and we should’nt be able to validate without it. :slight_smile:

Thank you again!


hi @Joachim_Brindeau - thanks so much for reporting your findings on that, and I’m glad it was eventually sorted out! I’ve gone ahead and created an internal ticket so our team can look into marking those fields as mandatory.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.