Webhook and 0x1fffffe8 Problems


I have two N8N servers both are in OCI with SSL and Reverse Proxy (NginX).
I have a server version 0.216 and the other in version 0.211.2.

Updated server stopped working accurately after update.
Webhook URL that previously worked perfectly now insists on staying localhost.

Error 0x1fffffe8 referring to 512 MB of memory also started to occur only and exclusively after update 0.216 on Ready Binary Files nodes.

My most important workflows stopped working.
I looked here in the forum for all kinds of information possible and none of it worked for any case.

As I work a lot with N8N in the company, I can say that the most reliable version is 0.211.2.

error: cannot create a string longer than 0x1fffffe8 characters —> never happened before

Information on your n8n setup

  • n8n version: Newest Version 0.216

  • Database you’re using SQLite —> I tried mysql but even with the correct variables it ignores it and uses SQLite

  • Running n8n with the execution process [main]:

  • Running n8n via [npm]:

Is it possible that it has nothing to do with the version rather that now larger files get used than before? Because that limitation was always there since the very first version of n8n.

It can be overcome by using the binary data mode filesystem:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.