Webhook error

Hi n8n team, Happy new year, Hope you have a great year.

Not sure why but when I run my workflow it says: [My Webhook] can not be activated because another one with the same method “GET” and path [some path] is already active!
I changed the Path, also I removed the workflow and created new one but I faced this error again and again.

I saw in another topic which this bug is fixed. I wonder if you can send the link of that PR that fixed the problem.
Thank you very much.

Hey @jellybean!

Wish you the same!

Can you please share how you’re running n8n?

Just took a look at the changelog and I am not sure what fix are you talking about. However, you can update n8n to the latest version which has also the fixes.

@harshil1712 Thanks.

I cloned this project from another server, so far I made a lot of change on it. I’m afraid I cannot pull the latest version.
Also, where can I found the version number? I want to compare it to original project.

You can use the n8n -v command to check for the version. Also, while cloning from another server, did you also cloned the database? If you did, that would probably be the issue here. Since the Webhook URL is already registered, it won’t allow you to register it again.

My version is : 0.88.1. What is the original one?
Also we cloned the database. In DB I can see the webhook_entity table, Do you mean that?

Dears, I found the issue. I tried to execute from another component using emit. And in the NodeView I ran this.runWorkflow();
Seems this is the problem.

Thanks again for you help :slight_smile:


I am glad you figured out the issue! Have fun :slightly_smiling_face: