Webhook IP whitelist option

I’m on-premise. Does it change anything?
I’m using a simple webhook node, and I’ve added the option to whitelist IPs. Even when I whitelist the only IP that I know the request comes from (versus a range of potential IPs), the webhook never gets called.
Also, I don’t see the option in the doc, that’s weird.
Has anyone faced the same problem?

What is the error message (if any)?

when trying it from Postman I’m getting the following error:

IP is not whitelisted to access the webhook!

Also, when removing the option, the webhook is called, no problem.



## Information on your n8n setup
- **n8n version:** 1.42.1
- **Database :** PostGresql 16 
- **n8n EXECUTIONS_PROCESS setting (default: own, main):** no clue
- **Running n8n via (Docker, npm, n8n cloud, desktop app):** Docker
- **Operating system:** not sure about that one either

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Sdyb,

If you are using a reverse proxy it could be that all of your requests are coming in with the IP of the proxy. It could be that you need to set something like X-Forwarded-For in the proxy for it to work.

1 Like

Gotcha thanks Jon. Indeed all the requests are coming with the IP of the proxy!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.