Webhook is not receiving anything

I finally was able to install n8n on DigitalOcean but when I try to build my first workflow by using a Webhook trigger it is not receiving any info from my CRM.

There is no error just a spinning wheel and that’s it. If I use the browser and follow the webhook link the trigger works.

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n latest:
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • **Running n8n via [Docker]

I believe I might be doing something wrong but works fine in Integromat.

Thank you for all the help in advance.

Hey @kgurinov

There are a couple of things you have to check.

Can you make sure you’re using Test URL (for Testing Purpose) and POST is selected?

If it’s fine can you check you have WEBHOOK_TUNNEL_URL in the Environment Variables?

It should have your n8n instance URL.

example: https://n8n.mydomain.com

If it’s not set, You can refer to this part of the documentation to set your Webhook Tunnel URL

or Watch this video (Included Timestamp) by @harshil1712


I suspect @mcnaveen is correct, if you press execute it will be waiting for some data to call the test webhook url. If you use the live url you won’t see the data in the interface unless you check the execution logs.


Guys that helped i was using Get instead of Post since logically made sense to me. Now everything is working like a charm.


Hi @mcnaveen

Could you please tell me about

It should look like this (for example)? :

 - WEBHOOK_TUNNEL_URL=https://n8n.mydomain.com

1 Like

Yes, That’s correct

1 Like

My Portainer N8N install has

- WEBHOOK_URL=https://n8n.mydomain.com

instead of

- WEBHOOK_TUNNEL_URL=https://n8n.mydomain.com

Could this be what's affecting my receiving of Webhooks?

It should be WEBHOOK_URL, The older option was WEBHOOK_TUNNEL_URL.

Super - thanks!