Webhook node ERROR: ENOENT: no such file or directory, open '/tmp/12c77b592ffcb06bdd075cc07'

Describe the problem/error/question

I am getting the following error when using the Webhook node to receive incoming responses.

What is the error message (if any)?

ERROR: ENOENT: no such file or directory, open ‘/tmp/12c77b592ffcb06bdd075cc07’

Please share your workflow

How to fix this error? I am on the latest stable version.

I have tried referencing the previous mentions of this error, but they are related to Windows operating systems and File Paths.


But I am running Linux as the OS and Docker on top of it. My volume mappings look like this:

Can someone assist me on this, as all our workflows are failing to run.

Information on your n8n setup

  • n8n version: 1.8.2
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 22.04 (LTS) x64 instance running on DigitalOcean

Hi @Jayavel :wave: Thanks for showing what threads you’ve already checked out!

Can you post your full docker-compose file? Someone else had incorrect mapping, and changing this + a restart fixed this for them as well:

Hi EmeraldHerald,

Sure, here is my docker compose file:

version: '3.8'

    image: postgres:11
    restart: always
    container_name: n8n_db
      - /data/n8n/db:/var/lib/postgresql/data
      - ./init-data.sh:/docker-entrypoint-initdb.d/init-data.sh
      test: ['CMD-SHELL', 'pg_isready -h localhost -U ${POSTGRES_USER} -d ${POSTGRES_DB}']
      interval: 5s
      timeout: 5s
      retries: 10  

    image: n8nio/n8n
    restart: always
    container_name: n8n_app
      - DB_TYPE=postgresdb
      - DB_POSTGRESDB_HOST=postgres
      - N8N_EDITOR_BASE_URL=My Editor URL
      - WEBHOOK_URL=My webhook URL
      - GENERIC_TIMEZONE=Asia/Kolkata
      - TZ=Asia/Kolkata
      - N8N_EMAIL_MODE=smtp
      - N8N_SMTP_HOST=smtp-relay.gmail.com
      - N8N_SMTP_PORT=465
      - N8N_SMTP_USER=my email
      - N8N_SMTP_PASS=my app password
      - N8N_SMTP_SENDER=my email
      - N8N_SMTP_SSL=true
      - 5678:5678
      - postgres
      - /data/n8n/app:/home/node/.n8n
      - /data/n8n/files:/files
        condition: service_healthy

Please note that I am not using Docker Volumes for this, as we have a custom backup solution which backs up all the folders inside the ‘/data’ root folder.

I looked at the other thread you have provided. You have explained about the Docker Volumes. Since it was working fine for me till last week or so, I tried deleting the containers and re-pulling the latest one and restarted the server. Same results.

Hmm, I’m not too sure on this one, @Jayavel . Maybe @marcus who is in today or @Jon who is back on Monday might be able to give you a more definitive answer as to what’s happening here :see_no_evil: If you have any logs to share, that would also be helpful!

The logs doesn’t show any valuable info regarding this particular error.

Attaching it here either way: (Taken from Portainer)

n8n ready on, port 5678
Initializing n8n process
Version: 1.8.2
   Start Active Workflows:
   - Workflow 1 (ID: 3tipDJ3NlOiTXcf0)
     => Started
   - Workflow 2 (ID: toCIkwlWmPHZiYjm)
     => Started
   - Workflow 3 (ID: w9NFb0k95CuMc2Z1)
     => Started
   - Workflow 4 (ID: jdQxZ3a4iv5ZIryr)
     => Started
   - Workflow 5 (ID: Ttr5VKrrkkoxX21x)
     => Started
   - Workflow 6 (ID: qaskMf64qiMGeCrY)
     => Started
   - Workflow 7 (ID: xEC7RUIjsuLllBsb)
     => Started
   - Workflow 8 (ID: FZ3emBJCmCjGHjOP)
     => Started

Editor is now accessible via:

This is pretty much it.

Hi @Jayavel - I’m not too sure, but this might be related to the binary data that you’re getting sent by the Webhook node. Does this only happen when you’re manually running the workflow, or when you get a specific request? :thinking:

If it only happens with a request, can you provide an example of the request you’re sending over with the webhook? :+1:

No, this isn’t specific to any binary data/request. I even tried sending a simple text entry to n8n to see if it works, it just throws the same error.

Pls check this as we have some production workflows running on this.

Hey @Jayavel,

I am not able to reproduce this, Can you share a test curl command that can be used to trigger this? Can you also try and set N8N_DEFAULT_BINARY_DATA_MODE to filesystem to see if that changes anything?

Will try this and see.

Using this env variable doesn’t fix the error. Is there any other workaround for me to try?

I’ll check if I can get any sample curl command, but as of now, we only use Appsmith to send data over to n8n for processing and display the results to the user.

I even checked using the official repo compose example, unaltered.

Getting the same error still. So, will it be related to the Appsmith config somewhere? But, how does it throw up an error saying “no such file or directory, open ‘/tmp/e942fdb1f7550e408f86fb800’” in n8n?

Hey @Jayavel,

I have just given that compose file a run and with a couple of post requests I am not able to reproduce the issue. It would be very helpful to know how / what you are sending so we can try and reproduce this.

This is the last entry that we tried from Appsmith.

Here, the Session ID and the Email fields are text fields and the rest are binary data fields.

I am not sure on how to transform this to a curl request, but we are only using some .docx and .xlsx files to be sent to n8n.

This has been working fine till last week or so. We did not face any issues and once we even processed around 15 files at the same time.

What does it say under errors?

This is the only entry:

What is the field name for the file you are sending?

Edit… I can see upload and quesUpload are both of those populated?

Yes, all of the binary fields are populated.

Also, we get the same error even if we send only the text fields and do not include any binary files.

I have just done a test with 3 files and some other fields but I still can’t reproduce this, It feels like it could be something with the setup of n8n or something odd being sent in the data.

Have you tried sending some data yourself from something like Curl / Insomnia / Postman to your endpoint to see if that fails?

Yes, after you guys asked for the curl sample, we are trying to get this checked using Postman. Once we do that, I’ll get back to you.

Hey Jon,

We were able to send data using Postman. It works fine. Tried attaching different binary data, and all gets received by n8n.

So, what are my options now?

Hey @Jayavel,

I guess now it would be a case of trying to get a curl request or similar out of Appsmith or sending the request to something like webhook.site to see what is there to try and mimic it