Webhook node won't stop listening for Trigger Event

Describe the issue/error/question

When I set up a webhook and then click “Listen for Test Event” the UI indicates that I should send a sample request to the webhook URL. I do so over Postman and receive a response

    "message": "Workflow was started"

However, the UI still says “Listening for test event” and doesn’t register the request I sent through Postman. If I send the Postman request again, I get

    "code": 404,
    "message": "The requested webhook \"POST 99811bca-fa5d-4a68-9df1-b38038c2dd12\" is not registered.",
    "hint": "Click the 'Execute workflow' button on the canvas, then try again. (In test mode, the webhook only works for one call after you click this button)"

I then try to stop the stop the listener but clicking the button simply does nothing. I saw in the web console that clicking the button sends a DELETE request to domain.com/rest/test-webhook/1 but the response is a 200 with a response body of {data: false}.

Then no matter what I do, the listener just won’t stop until I reload the entire page, after which the data from the initial request is gone.

Here’s the webhook node itself.

I started n8n using Docker and am using a subdomain to access the editor, which has worked fine so far.

Can anyone help point me in the right direction? What could be causing the Webhook Listener to ignore the request from Postman and then not close at all?

UPDATE: I noticed the following error in the web console which may be relevant. It’s shown when loading the page and regardless of whether or not I run the webhook test above.

Firefox can’t establish a connection to the server at https://domain.com/rest/push?sessionId=95xzt570sdd.

  "meta": {
    "instanceId": "21e90e30f2fd314f0d97ee4389a5fee22ba68261f1390deb70adb60e1d45dad8"
  "nodes": [
      "parameters": {
        "httpMethod": "POST",
        "path": "99811bca-fa5d-4a68-9df1-b38038c2dd12",
        "responseMode": "responseNode",
        "options": {}
      "id": "c81b1185-7d2f-45d2-bdff-a9f1da421fdb",
      "name": "Webhook",
      "type": "n8n-nodes-base.webhook",
      "typeVersion": 1,
      "position": [
      "webhookId": "99811bca-fa5d-4a68-9df1-b38038c2dd12"
  "connections": {}

Information on your n8n setup

  • n8n version: 0.212.1
  • Database I’m using: MariaDB
  • Running n8n with the execution process [own(default), main]: (default)
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

I actually found the solution to this in another post. I’ll leave this one here in case someone has the same issue and recognizes it from the post. The solution is to add the

proxy_buffering off;

setting to the nginx virtual host.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.