Webhook not processing all data

Describe the issue/error/question

I’m running a self hosted instance of n8n at Hetzner.
2 vCPU
4gb ram
40 gb ssd

I’m using n8n to trigger a workflow based on when a contact property changes in Hubspot. I’ve run a similar workflow successfully for several weeks now. Over these weeks it has only been manually changing a contact property, so in most cases 1 webhook sent at a time. Now I’m trying to batch change contacts in Hubspot Eg. 10 at a time. When tested I only get 8 workflow executions. I can see in hubspot that all 10 contacts received http 200 from n8n. I’ve also tested larger batches (50) and get the same result where n8n only runs X amount of workflow executions and the data never arrives in my other system.

My first thoughts are is this a scaling issue that n8n can’t handle all the requests / process of the workflow at once? Do I need run n8n like this: Configuring queue mode - n8n Documentation

Is there a smarter way to receive all the data first then loop through it until done?

I also tried to put a “respond to webhook” node at the end of the IF and last http post node but that caused hubspot to keep trying to send the payload multiple times.

What is the error message (if any)?

No errors are reported in n8n or hubspot

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.195.5
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hi @tonybelonie, it shouldn’t be a problem to process such a number of executions, especially with a compact workflow and small dataset like you’re presumably getting from Hubspot.

I just ran a quick test on my (very small) n8n instance and the 10 requests were processed as expected:

Is there a chance you’re simply not storing all executions in n8n? Are there any errors in your server log?

If you are certain your system load is causing the problem, you could consider using the throttling options offered by Hubspot: Webhooks API

@tonybelonie Very strange. Can you please also test changing from “own” mode to “main” (setting the environment variable EXECUTIONS_PROCESS=main) and see if that helps.